[ARCHIVE] SimAntics & World Development

Discussion in 'Development News' started by RHY3756547, Feb 16, 2014.

Thread Status:
Not open for further replies.
  1. jokergato

    jokergato New Member

    Thanks again :D :D :D
  2. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    OK, committing now. Things are still pretty early doors, so no removing walls yet. Try setting up some rooms and putting doors between em.
    NOTE: Modifying the world while sim routing is in progress will cause unexpected results, just like moving objects when sim routing is in progress. Not only that, but you'll notice that sims can actually walk through walls if they're not on a room boundary (standalone walls), which will not be fixed until I implement the new more accurate routing. (after build mode)

    Also, there are a ton of cases where things will go wrong (walls placed out of bounds CRASH THE GAME!), and walls do not check if they intersect objects. Don't say I didn't warn you!
  3. pisarz1958

    pisarz1958 Administrator Staff Member Moderator

    ALL THE POSSIBLE BAD DESIGN IDEAS IN ONE HOME (btw. who needs windows anyway)

    And it's a fine example of how unifinished routing is. "oh, so I got this book and I could sit on a sofa, but nope, I prefer sitting in a restaurant for no reason".
    Bob's logic <3

    Anyway, awesome work Rhys! I'm away for 2 days and suddenly... buildmode o.o
    yoyo, LetsRaceBwoi, AquilaSim and 4 others like this.
  4. pisarz1958

    pisarz1958 Administrator Staff Member Moderator

    Blayer98 likes this.
  5. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    The chair thing looks like a problem with the Find Best Object for Function primitive. The bookcase obviously searches for the "sit" entry point, but the same problem happens with all others. (food prep, eating surface..) Right now, it picks the first object with the function it can find. I'll quickly fix this, all I need to do is add the scoring system. I have a functional tuning distance attenuation value from Tunings.dat of 3, which I'm guessing means "-1 point every 3 tiles". I'll see what the object data score values turn out to be.

    Nice house, by the way ;)

    The stairs work like the doors, except the exit parts of the multitile object aren't on the second floor because it's not implemented yet (they are on the first!). So technically it's just a portal from the ground floor room into the same room.
    yoyo, pisarz1958, Marvin732 and 4 others like this.
  6. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Just fixed Find Best Object for Function. Now has distance attenuation and scoring! (works for food prep too, sim uses food processor)

    (same test, with the correct result ;) )
    Tori Sim, yoyo, pisarz1958 and 2 others like this.
  7. pisarz1958

    pisarz1958 Administrator Staff Member Moderator

    Thanks. :D I realized the rooms are a bit too small when it was already too late. And, well... there is no bathroom. Oops! Anyway, Shift+Left Mouse Button works great when it comes to placing walls, I didn't expect that.

    I'm not sure if it should take care about cutaway stuff when placing walls though. Does anyone remember/can check how this worked in TS1/TSO? Because it feels a bit weird and I don't know why.

    So the wrong offset is there because second floor tiles are moved a bit in that direction and character was supposed to be rendered like if he was on another floor (but he isn't because it's not supported) or I'm not getting anything right at all?

    Nice fix, Rhys :D And you even made identical room too~!
    LetsRaceBwoi likes this.
  8. cnnoi33

    cnnoi33 New Member

    rhys you are fucking amazing
    yoyo and LetsRaceBwoi like this.
  9. Marvin732

    Marvin732 Active Member

    Your little house is fucking amazing ! maybe i take it as a house creation idea
    pisarz1958 likes this.
  10. Afr0

    Afr0 Well-Known Member

    I'm currently in Estonia studying Russian for the next two weeks, so that's why no update has been pushed yet.
    But Rhys changed the projects to VS 2015, which should hopefully get me compiling on my laptop straight away (even though I almost had it working!) when I'll have time to work on Saturdays/Sundays.
    I already made the lot info request not crash the server, but the label hover-over-label still doesn't appear when hovering over lots. Rhys should probably double check my code before I have time to look at it, maybe I made a simple mistake...!
    Then there's the actual lot purchase - it could work straight out of the box or crash the server - it is still untested, so please don't click yes on the dialog!
    When these features are done I'll push a new update and spend probably at least a week carefully considering the technical implications of accessing individual lots.
    Blayer98, Tirea, Tori Sim and 3 others like this.
  11. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    When placing walls in TS1 they don't appear cut away when they're in the "not placed" form, which is probably the difference. I can add a cutaway exemption for that wall style.

    Thanks. 8O|

    @Afr0 I'll check on that later tonight when I'm back at my pc.
  12. pisarz1958

    pisarz1958 Administrator Staff Member Moderator

    I have a confession to make.

    ... and nothing happened, not even a crash.
  13. francot514

    francot514 Well-Known Member

    Good work for your progress Rhys, i want to check for something, if you already know that:

    -When selecting wall tool, it draws even when i do click in different window, not game itself.
    -When crossing walls the object wall cursor wil not allow you to go trough walls, when using diagonals
    -Using the wall down view, changes wall lookout to only top down edges, that should not happen.
    Blayer98 likes this.
  14. yoyo

    yoyo Active Member

    Wow! All this progress is awesome! :D :D
    I don't know what else to say, this project is surprising me with every new update :)

    Home Sweet Home!
    Last edited: Jul 16, 2015
  15. mallhew

    mallhew Member

  16. zc456

    zc456 Well-Known Member

  17. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Hmm, looks like it was deleted for some reason? Our build process has also changed since then, so it would be wrong anyways.

    The easiest way to get one of the pre-release builds that we're discussing here is to use on of the builds on our TeamCity page, which there's a link to in my signature (build-mode is the current working branch). If you want to compile the code yourself, you should download Visual Studio 2015 and Monogame 3.4, then clone our Git repo and open tso.client.sln.

    Remember that if you want to run PD at all you'll need to download the original game at http://largedownloads.ea.com/pub/misc/tso/ .

    Shouldn't those resolve automatically on first build?
  18. zc456

    zc456 Well-Known Member

    *checks* Oh, you're right. I wonder if that setting somehow got unchecked (if it was ever checked) for me on VS.
  19. mallhew

    mallhew Member

    Creating some dummy-proof instructions for future reference.
    Please point out any missing steps or misunderstandings:

    To run the game without compiling code:
    1. Download the original TSO game: http://largedownloads.ea.com/pub/misc/tso/
    2. Install TSO (note: wait for "Installing" to reach 100%, then hit "cancel" as making an EA member account is not helpful.)
    3. Head to TeamCity and login as guest
    4. Download latest build by clicking on the arrow next to highest "Success!" in list after clicking on latest branch (currently build mode), then click the arrow next to "View" in the "Artifacts" column and download the zip file.
    5. Click tso.client.exe
    To run the game by compiling code:
    1. Download the original TSO game: http://largedownloads.ea.com/pub/misc/tso/
    2. Download and install Visual Studio Community 2015 RC: https://www.visualstudio.com/en-us/downloads/visual-studio-2015-downloads-vs.aspx
    3. Download and install Monogame 3.4 for Visual Studio: http://www.monogame.net/2015/04/29/monogame-3-4/
    4. Clone the Github repository for PDH: https://github.com/Afr0Games/Project-Dollhouse (hit "download as ZIP", or through git commands in terminal - which can let you pull changes quickly)
    5. Open tso.client.sln
    Anything that's missing?
    Last edited: Jul 16, 2015
    yoyo and Tori Sim like this.
  20. francot514

    francot514 Well-Known Member

    You forgot mine post xd??
Thread Status:
Not open for further replies.

Share This Page