[Call for Testing] Client with DX9 support for Intel GMA

Discussion in 'Support' started by RHY3756547, Feb 20, 2016.

  1. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Can someone who wasn't able to get the game running at all (either invisible objects or immediate crash) try with this build:

    https://dl.dropboxusercontent.com/u/12239448/Debug.zip

    The depth will be broken a little bit in lots (weird offset), but if it works at all I can fix the build. You will need DX11 installed, but you only need a DX9 card to use it!
  2. Simhrique0990

    Simhrique0990 Active Member

    I tested in my trash GPU , the game is very speed now, but my graphics card and not intel gma,
    The game, usually works .. the map is no lag , so the sims and objects very strange
  3. Fraczek20

    Fraczek20 Member

    I don't want to be rude to you but your English is pretty broken.
  4. Simhrique0990

    Simhrique0990 Active Member

  5. LetsRaceBwoi

    LetsRaceBwoi Well-Known Member

    not his first language, not his fault really
    zc456 and Simhrique0990 like this.
  6. Simhrique0990

    Simhrique0990 Active Member

    Yes,my language is portuguese
  7. LetsRaceBwoi

    LetsRaceBwoi Well-Known Member

    eu falo um pouco português
    (it's terrible though lol)
  8. Simhrique0990

    Simhrique0990 Active Member

    Perfect, better that my Inglês :p
    LetsRaceBwoi likes this.
  9. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    upload_2016-2-20_22-10-10.png
    Just fixed a ton of bugs. Still calling for people with Intel GMAs to test!
    Anyways, in future this mode will be accessible by adding the "-dx11" to any shortcut. It will not be usable from linux and mac... though they will be receiving a dynamic linker to switch in the correct version of monogame.
  10. Fraczek20

    Fraczek20 Member

    On Intel GMA 3150 CAS works but then the game carsh with "Parameter is incorrect" error.
  11. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Post a screenshot?
  12. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    OK, looks like old GMAs (3150/950) do not support Multi-Target render and the Single surface format, which means supporting them would require a lot of effort. Just ignore it for now.
    Fraczek20 likes this.
  13. Fraczek20

    Fraczek20 Member

    Ok
  14. Simhrique0990

    Simhrique0990 Active Member

  15. francot514

    francot514 Well-Known Member

    Just tested this DX11 build and get some error:

    tsodx.png
  16. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    There appears to be something wrong with your config file. The latest build should also have the -dx11 change, so try that. If that doesn't work, delete your config at %AppData%\..\Local\FSO\
  17. francot514

    francot514 Well-Known Member

    Done, and now working with no problem, this build is only for testing Intel Graphics compatibility??
  18. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    The official builds should now support -dx11, it's for switching to if you have any problems with ogl.
  19. TsJA101

    TsJA101 New Member

    Unfortunately the download link no longer works. Is there a new download link?
  20. Blayer98

    Blayer98 Active Member

    Go to servo.freeso.org for any new builds.

Share This Page