Crash windows 7 intel 965 chipset

Discussion in 'Support' started by quarter187, Nov 24, 2015.

  1. quarter187

    quarter187 New Member

    i have tried everything imaginable to get pdh and freeso running on my computer. No matter what i do it continuez to crash with the same error every time. I know the issue iz my crapy gpu on this thing yet i am really dedicated to play tso with my frindz again. And this computer is all i have at the monent. Iz there anythig that can be done? :mad:
    [​IMG]
  2. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Try updating your graphics drivers, if anything is available it should come with a newer version of opengl with that entry point.
  3. quarter187

    quarter187 New Member

    I updated it. Through intel updater. Found 2014 driver i beleive Im sure it supportz opengl 2.0 but dozNt freeso require opengl 3?
  4. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    OpenGL 2 is the minimum required for monogame, though some features are used that simply might not work on prehistoric intel cards...
    xXJDrocks450Xx likes this.
  5. quarter187

    quarter187 New Member

    i juzt want it to run. Perhaps if i install monogame it will install some dependenciez.
  6. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I don't recommend doing this, but just out of curiosity you could try this version of opengl32.dll I got with the more recent intel/nvidia combo laptop driver updates:

    https://dl.dropboxusercontent.com/u/12239448/opengl32.dll

    Place it in the FreeSO directory right next to the exe. Please save everything that you're doing before trying this, it might cause a hard restart (bsod) if there's something the driver isn't equipped to handle.
  7. LetsRaceBwoi

    LetsRaceBwoi Well-Known Member

    did anyone else tilt their head 90 degrees clockwise or just me
    Also, why are you using an Intel 965 chipset in 2015? Do you have any idea how old and outdated that is? Your description concerning your graphics chip is also vague. You could be describing the GM965, the Q965, the GME965, or the G965. I'm going to go for a stab in the dark and say that you're using the GM965 (since you took it with a phone I assume you're using a laptop). In this case, why are you using a laptop pre-2010? Like, 1GB RAM? You can get some cheap laptops with some sweet specs (especially since Black Friday is nearly among us).
    ... That's pretty dangerous, and is one of the most dangerous things you could do apart from using graphics drivers from an AMD/nVidia GPU on an Intel GPU. You're either going to get BSODs every time FreeSO is opened with that dll inside the folder, or there's a small chance it could work with horrible anomalies (since it was likely not compiled for the early mobile graphics bullshit architecture, which is why an older version is being used); either way it's probably not going to produce desirable results. If it does, you're one lucky guy.
  8. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    No, using a different OpenGL dll is not one of the "most dangerous things" you can do. If your graphics card could delete files, it might be, but that's never going to happen.
  9. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

  10. quarter187

    quarter187 New Member

    I have tried it all. I installed monogame witch did install some dependanciez. I tried both your opengl filez and they gave me this error.
    [​IMG]
    [​IMG]
    However ever since i installed monogame i recieved the 'void tso.world.worldcontent.init' error. So i removed tso.world.dll (i have pdh installed azwell) yet now the exe startz up. Showz a white box for a momment then crashes with no report. I have made progress so i know i can get freeso running on this laptop.
    [​IMG]
  11. quarter187

    quarter187 New Member

    Opengl specz of my gpu
    [​IMG]
    [​IMG]
    It should be able to run pdh/freeso i dont understand
  12. -BloodFighter-

    -BloodFighter- Active Member

    I would recommend you to use this: https://gyazo.com/ , instead of making photos of your screen with a phone camera^^
  13. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I think monogame requires OpenGL 2.1, not 2.0. Not sure why mesa isn't working, that doesn't make much sense.
  14. quarter187

    quarter187 New Member

    I have found an opengl.dll to force opengl 2.1 on my exact video card. (It works with minecraft) the error i am recieving now is in short. OpenTK.Graphics.GraphicsContextException: Requested GraphicsMode not available. SetPixelFormat error: 127
    Perhaps work on an opengl32.dll to bypass the opengl 2.1 on lower systems could be made?
    It juzt soundz like the hardcoded graphicz optionz need to be edited and a (low def) freeso file could be released.
    Could this be done?
  15. jkjoebo

    jkjoebo Member

    PrintScreen button and paste in paint save as and upload to tinypic
    Thats what i usally use for full screen pics sence gyzmo uses download icon\files
    Might have to wait for optimization sence you have on board graphics iv got a 2.5ghz amd 8gigs of ram with a 2gigs dedicated accerator card windows 8.1 1tb drive laptop it still lags on me but alot of games still have to be set to lowest setting
  16. quarter187

    quarter187 New Member

    I do use tinypic. I waz juzt simply snaping the imgagez and uploading them from my phone because for one i was logged into the forums with my phone and for two because my browser is anoyingly slow because of the outdated computer. Itz juzt all i have atm untill next month sometime.
  17. quarter187

    quarter187 New Member

    if your specz are that high you should have no lag. Perhapz itz crapy windowz 8. Try downgrading to win 7 ultimate. Would be my recommendation.
  18. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    2DWorldBatch refactor is coming soon to speed things up a lot (>4x in motion likely, low cpu idle cost), though I have other commitments right now so it might be a while off. Its not going to change the requirements though. When do you get that error? If it's when the lot is created, it's likely because I'm using the "single" surface format for render targets.
  19. jkjoebo

    jkjoebo Member

    Just putting windows 7 would be bad without corect drivers sence my laptop came with win 8.1
  20. LetsRaceBwoi

    LetsRaceBwoi Well-Known Member

    no.
    It's likely that jkjoebo has some background programs, but laptops are usually horrifically laggy unless you cash out £1-2k on one, but you could get a nice desktop for much less that could handle games a lot better. Sometimes it's to do with overheating, or to do with the fact that everything has to use less power in a laptop (portability is key) and therefore things don't perform as well. There are some really swell laptops out there, but desktop is always best (especially for custom builds) for performance : price ratio.

Share This Page