Error while trying to open Freeso

Discussion in 'Support' started by felix11, Jan 6, 2017.

  1. felix11

    felix11 New Member

    Hi,

    So, I reinstalled the game from the newer launcher at http://play.freeso.net/

    and now I am getting this weird error message when I try to open up FreeSo.

    I had the game working before and was on it.. ?

    I tried to delete/uninstall and start over again, but another window pops up and says the Freeso file is in use and open in another program/file ?

    Attached Files:

  2. The Architect

    The Architect Administrator Staff Member Moderator

    Did you run the installer on Admin? Are you opening FreeSO as an admin?
  3. mrpenguinb

    mrpenguinb Active Member

    nicefungirl had the same problem, its to do with your "InstallDir" registry entry. You need to change that to your current install of TSO.
    The Architect likes this.
  4. jessamica92

    jessamica92 New Member

    I got the same error as well. How do you change it?
  5. Hayran

    Hayran New Member

    @jessamica92

    1 - First, open notepad and type in the following syntax:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Maxis\The Sims Online]
    "InstallDir"="C:\\Program Files\\Maxis\\The Sims Online\\"
    "GameDir"="TSOClient"
    "GameExe"="TSOClient.exe"
    "PatchDir"="TSOPatch"
    "PatchExe"="TSO.exe"
    "TotalBytes"=dword:61c27ce7
    "ProgramFolder"="Maxis\\The Sims Online\\"
    
    
    2 - Save the text tile to your computer then right click on it and rename it with a .reg extension. Now when you double-click this file, it will make changes to the registry.

    OR

    Download the file attached and rename to .reg

    PS: If you installed somewhere different, change the location of the file in Notepad.

    Attached Files:

    • TSO.txt
      File size:
      672 bytes
      Views:
      30
  6. jessamica92

    jessamica92 New Member

    Thank you! I'll let you know if it works
  7. Hayran

    Hayran New Member

    Np :)
    If you system is 32bits, change the code to it to below:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Maxis\The Sims Online]
    "InstallDir"="C:\\Program Files\\Maxis\\The Sims Online\\"
    "GameDir"="TSOClient"
    "GameExe"="TSOClient.exe"
    "PatchDir"="TSOPatch"
    "PatchExe"="TSO.exe"
    "TotalBytes"=dword:61c27ce7
    "ProgramFolder"="Maxis\\The Sims Online\\"
  8. jessamica92

    jessamica92 New Member

    hmmm it didn't work :/ I restarted my computer and I am going to re install it one last time.
    Hayran likes this.
  9. Hayran

    Hayran New Member

    OMG :( If I can find a solution, I will send...

    @To DEV of launcher
    OMG :( [​IMG]

    I sent the tuning.dat file to user but that was giving error. He reported this picture problem. It uses Windows 10, it has Windows Defender turned off, it does not have antivirus, it has framework and never installed TSO (dir test etc).
  10. Alex F.

    Alex F. Member

    "Unable to read beyond the end of the stream" - sounds like it's trying to read further than it should be, is the file complete (i.e. not corrupted)?
  11. jessamica92

    jessamica92 New Member

    now I am having a error trying to install the game oh boy :/
  12. Hayran

    Hayran New Member

    I think the file corrupted, but I do not know the cause. I wanted to find the problem. One of the user have Windows 10. Do the ones above also have?

    @jessamica92

    Try download again :X, but first, delete the Maxis/The Sims Online folder.
    We need to find this error and solve it.
  13. Alex F.

    Alex F. Member

    Has he tried re-downloading the file, or re-downloading it with antivirus temporarily disabled?
  14. jessamica92

    jessamica92 New Member

    yea I just re downloaded the files and deleted all the old stuff :/
    I have Windows 10.
  15. The Architect

    The Architect Administrator Staff Member Moderator

    make sure you run everything as admin
  16. Hayran

    Hayran New Member

    It seems to be some problem with Windows 10 and the installer. The files are not installing, so it is giving the error above:

    [​IMG]

    Normal (correct without FreeSO laucher)

    [​IMG]
  17. jessamica92

    jessamica92 New Member

    I would have problems right before Beta Launch haha. It was working fine before. I was able to jump in the game and interact perfectly fine.
    felix11 likes this.
  18. Hayran

    Hayran New Member

    I'm uploading my files to Google Drive, it will take a few minutes. Then you download and put the files there, and see if it works.
    Last edited: Jan 6, 2017
  19. jessamica92

    jessamica92 New Member

    It actually is working now! crossing my fingers it stays working haha.
    Hayran likes this.
  20. Hayran

    Hayran New Member

    LALLLLLLLLL What did you do?

Share This Page