FreeSO Launcher yields nothing but a blank white screen (Windows 11)

Discussion in 'Support' started by CreatorJo, Mar 3, 2023.

  1. CreatorJo

    CreatorJo New Member

    I'm having an unusual issue in which the launcher for FreeSO isn't showing anything but a blank white screen. The popups work just fine, it's only the main app's window that isn't working.
    I have used Winaero Tweaker (and Win11DisableOrRestoreRoundedCorners) to tweak some things regarding my OS's functionality and appearance, but I don't think this should have an effect.
    Any help would be appreciated.
  2. CreatorJo

    CreatorJo New Member

    Seems like everything but the forums are down right now. Right when I wanted to get back into this game. ._.
  3. CreatorJo

    CreatorJo New Member

    Okay, looks like the game's back online, but the launcher is still not working. Will try re-installing.
  4. CreatorJo

    CreatorJo New Member

    It's still not working and it's saddening how inactive these forums are.
  5. CreatorJo

    CreatorJo New Member

    I copied the game files over from another computer that I have, and they run just fine without the launcher. Guess I won't be needing any help after all.
    Thanks for nothing.
  6. raikantopenknee

    raikantopenknee New Member

    Hey, I have this same problem. Any ideas?
  7. CarlosBM

    CarlosBM New Member

    Same problem here. I wanted to reinstall the game, but the launcher showed nothing. Got Windows 11 as well.
    I had to resort to the latest release on the GitHub repo and the official TSO installer. But I don't know how updates will be handled, and I am unable to change the game's language.
    I hope that the person responsible for the launcher will look into this.

Share This Page