FreeSO on Linux!

Discussion in 'Announcements' started by RHY3756547, Feb 8, 2016.

  1. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Functions in mesa software renderer now, but you also need libsdl2-2.0-0 to get the game to boot, and you have to make sure MonoGame.Framework.dll is deleted from the game directory. (it seems to forget to do that)

    Due to the changes made to monogame (DynamicSoundEffectInstance), no freeso compatible mac build of monogame is presently available.
    notonetotalk and NubSmoo like this.
  2. RainbowSims

    RainbowSims New Member

    Nice changes, I Might re-download FreeSO Again to see what is up with the community.
  3. wiltors42

    wiltors42 New Member

    I was getting the same error that Linuxer was getting, do I deleted Monogame/windows and now I am getting this error:
  4. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    That is weird, it should be looking for SDL2.o or something on linux, not dll. I'll have time to look into it later but not now... try copy the files from Monogame/Linux/ into the FreeSO folder itself. (specifically monogame.framework.config)
  5. wiltors42

    wiltors42 New Member

    Ok I had the game files installed incorrectly. It was a little confusing and there were no Linux specific instructions. Maybe there should be a sticky. I am now having the graphics glitches but the game launches! Is there a fix for the graphics yet?
    Last edited: Jul 8, 2016
  6. Linuxer

    Linuxer New Member

    How did you reinstall the game files in order to fix the problem about the missing SDL2.DLL?

    Fore those who are interested: The weird graphic that I reported in dist-255 also occurred when using the nvidia-drivers 367.35. It's apparently neither a problem specific to mesa nor an outdated nvidia-driver.
  7. wiltors42

    wiltors42 New Member

    I had to install libsdl2-2.0-0:i386. Even after it launched I wasn't able to play it because of the graphics problem.
  8. Linuxer

    Linuxer New Member

    I think I cannot fully follow. For me it still looks like:

    $ sudo apt-get install libsdl2-2.0-0
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    libsdl2-2.0-0 is already the newest version.[…]
    0 upgraded, 0 newly installed, 0 to remove […]
    ~/TheSimsOnline/drive_c/Program Files/Maxis$ mono FreeSO.exe
    [ERROR] FATAL UNHANDLED EXCEPTION: System.DllNotFoundException: SDL2.dll
      at (wrapper managed-to-native) Sdl:GetVersion (Sdl/Version&)
      at Microsoft.Xna.Framework.SdlGamePlatform..ctor (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
      at Microsoft.Xna.Framework.GamePlatform.PlatformCreate (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
      at Microsoft.Xna.Framework.Game..ctor () [0x00000] in <filename unknown>:0
      at FSO.Common.Rendering.Framework.Game..ctor () [0x00000] in <filename unknown>:0
      at FSO.Client.TSOGame..ctor () [0x00000] in <filename unknown>:0
      at FSO.Client.GameStartProxy.Start (Boolean useDX) [0x00000] in <filename unknown>:0
      at FSO.Client.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 
    Or do I specifically need the i386-Variant?
  9. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Your game is looking for the windows DLL. Copy the contents of /Monogame/Linux/ into the root directory, should include the metadata for linux build. Not currently dealing with that correctly.
  10. Linuxer

    Linuxer New Member

    Thank you! Now, it works and it's truly perfect.
    Screenshot from 2016-08-04 22:02:33.png Screenshot from 2016-08-04 22:03:16.png Screenshot from 2016-08-04 22:03:53.png
  11. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Not my fault and still no idea what is causing it...
  12. Linuxer

    Linuxer New Member

    I'm not blaming you. Just informing about the current situation.

    If there is any helpful information I can gather and provide (or tools to run), just tell me.
  13. Ohhuh

    Ohhuh New Member

    Will a Linux version be available on the January 6th or will it only be available Windows currently?

    Thank You
  14. Xondak

    Xondak New Member

    Here's a question: is anyone extracting the game's data from the installer? Do you have to install the game using WINE and then play it through mono? Is there a zip somewhere?
  15. nrg700

    nrg700 New Member

    The Game works well on my Ubuntu 16.04 LTS (2D and 3D Mode). I Barely Get Lagpits Which perhaps is caused by Hardware Incapabilities . I Haven't found any glitch or bug yet[​IMG] [​IMG]
    Last edited: Jan 31, 2018
  16. nalina

    nalina New Member

    Did you follow this guide? I created a Lutris script that runs through the steps in that thread, but I do get occasional error spam but it works through it.
    Last edited: Feb 7, 2018
  17. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    They likely followed a similar approach to the Mac guide, which mainly only works since Mac has a unix terminal and library ports.
  18. zoey

    zoey New Member

    Use the Discord app on Linux too? Want your Discord friends to see what FreeSO lot you're at without having to launch the game? Download from Discord's GitHub, unzip the file and paste discord-rpc/linux-dynamic/lib/ into the FreeSO folder, and your discord will show


    When in a lot, (The icon changes based on what lot type you're in. Just went to a money lot and the hammer changed to a $) and shows

    when not in a lot.

Share This Page