FreeSO on Mac

Discussion in 'Support' started by RHY3756547, Nov 30, 2017.

  1. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Hello all,

    It does turn out that we were always quite close to having the game run on Mac, it's just a few initialisation and library issues that caused it to fail at booting. With the correct files in the correct folder, it should be possible to run the next Windows build of FreeSO natively on Mac, and perhaps Linux. This does not require a special build of FreeSO, just a few extra files and the new version.

    [​IMG]

    On Mac, the game will assume the game files are in your ~/Documents/ Folder, for example: /Users/rhys/Documents/The Sims Online/TSOClient/TSOClient.exe should be the original TSO game executable. The same goes for Simitone, which looks for TS1 in ~/Documents/The Sims/

    Preliminary - Trusting FreeSO programs
    Getting started, you might encounter a lot of roadblocks with Mac trying to stop you installing non-app-store applications. To get around this, open up "Security & Privacy" (findable in spotlight search) and click "open anyways" each time you are asked.

    Installation Instructions:
    • Download the Mac Extras zip here: http://freeso.org/stuff/macextras.zip
    • Extract the Mac Extras into your FreeSO folder.
    • Run freeso.command or freeso3d.command to start the game! (these run mono FreeSO.exe through your terminal) You will need to update at least once.
    IMPORTANT: UPDATING
    • Updating FreeSO is more difficult. After the game's update finishes, the updater will not run. You must run freeso.command or freeso3d.command again, where you will see it performing the update in the command line.
    • Additionally, the game will not properly close until you close the terminal window hosting it. This is pretty unclean, but it works for now.
    • Check back at this thread after updates just to check if this process has changed, or if you need new MacExtras.
    That's all. All of this is less than ideal, but it should let you play the game without the crippling issues you might get on a VM for now. Hope it works for you!
    Rhys.
    Last edited: Nov 30, 2017
    dotequals, Alonzo, JimDog and 5 others like this.
  2. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I screwed up a little - the macextras zip has been updated again. Let me know if it works for anyone. (additionally, gettso.sh does appear to work correctly on mac, though you may need to manually delete the downloaded cab files afterwards.)
  3. JWofles

    JWofles Active Member

    This is awesome.
    [​IMG]
  4. dotequals

    dotequals New Member

    If you're taking advantage of iCloud Desktop & Documents Folders syncing and would prefer to keep that 1.64GB out of iCloud, you can create a symbolic link. My example assumes the folder The Sims Online is placed into ~/Local/Documents/
    Code:
    ln -s ~/Local/Documents/The\ Sims\ Online ~/Documents/The\ Sims\ Online
    NOTE: You must use a symbolic link. Making an Alias via the GUI will not work.

    There's also a known monogame or SDL issue with multiple monitors and/or multiple monitors with different DPIs that can cause what you're selecting to be about 200pts below the cursor. I had zero issue on my MacBook Pro's built-in display though.
  5. Josbo

    Josbo New Member

    When I try to download the build from TeamCity it only downloads a log file
  6. mrpenguinb

    mrpenguinb Active Member

    You have to download the right file. You have to view the artifacts to get the dist zip file (contains other files in it)
    Here.PNG
  7. Stacks

    Stacks New Member

    Tried doing this install today. Got through everything then went to run the freeso.command and freeso3d.command and it keeps telling me command not found. Not sure what I did wrong if someone could help me out.
  8. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Sounds like mono is missing. Make sure you installed mono and sdl.
  9. Stacks

    Stacks New Member

    It's ok I tried everything I could. Giving up on it.
  10. Tirea

    Tirea Active Member

    Is Volcanic going to be supported on macOS in the future?
  11. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Nope, MacOS doesn't support windows forms at all (it segfaults).
  12. Tirea

    Tirea Active Member

    Alright, thanks for clarifying.
  13. JimDog

    JimDog New Member

    Thank you, Rhys! I didn't have any problems at all getting it working by following your instructions. This is one of the main reasons I haven't been playing because I only have Macs and having to using Windows through Boot Camp just to play was really annoying.
    JWofles and mrpenguinb like this.
  14. LakenRN

    LakenRN New Member

    I am having major issues. I'm not sure if I installed Mono or SDL wrong but when I go to run it, it won't open. Is there anyone that can help? Or post a tutorial maybe on youtube or something? I'm dying to play and I've been trying for over 3 days to figure out what I'm doing wrong but can't figure it out.
    Ocirne and laurenpayne like this.
  15. Ocirne

    Ocirne New Member

    Wow, this is so amazing, have so much gratitude! I got a bit lost at the end of the instructions, like LakenRN said, a youtube tutorial would be amazing by someone if they had the time, that would be so helpful!

    Edit: I successfully downloaded and extracted everything without error, but when I try to run freeso.command it comes up with the error:
    "Got a SIGSEGV while executing native code. This usually indicates a fatal error in the mono runtime or one of the native libraries used by your application."

    and mono 'quits unexpectedly'.. do you have any thoughts? Thanks in advance!
    Last edited: Jan 24, 2018
    mrpenguinb likes this.
  16. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    This can indicate a few things:
    • You either didn't extract the mac extras correctly, or at all.
    • You didn't install the SDL2 framework correctly
    If both of these things have been done, you should post what the terminal that pops up says at the very top of scroll, as that's usually the C# exception.
  17. Ocirne

    Ocirne New Member

    Thank you so much for your response and help!
    I checked both of those things and tried again and the same error came up
    At the top it says 'The Carbon driver has not been ported to 64bits, and very few parts of Windows.Forms will work properly, or at all'
  18. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    There's a lot more text like that, you should just copy the whole thing. That usually pops up after the game crashes (it tries to show a dialog with win forms)
  19. KD1

    KD1 New Member

    Hi,
    Thank you so much for the instructions. FreeSO works perfectly on mac.
    I cannot seem to find a lot of information regarding Simitone... Is it possible to play TS1 on mac?
  20. Ice Cool

    Ice Cool Member

Share This Page