FreeSO on Mac

Discussion in 'Support' started by RHY3756547, Nov 30, 2017.

  1. Mikaelo

    Mikaelo New Member

    Success -- got it working on Mac :) If anyone has any questions feel free to hit me up -- I ended up using my Windows PC to copy the game files over since cabextract wasn't behaving.
  2. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    If anyone else is missing cabextract or any of the other binaries, try install them through Homebrew instead.
  3. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I've added new instructions that use Homebrew and our new TSO download source to the main post. These were written by @dotequals, so give him your thanks if they are helpful.
    dotequals likes this.
  4. JimGarb

    JimGarb New Member

    I know this is a rather old thread, but I've been unsuccessful in getting the application to start after an update process. I get a crash in the terminal. Of course I didn't record what the crash was (why would I think ahead?) I fixed it by deleting the contents of my "FreeSO" folder in Documents, re-downloading the updated version of the client and unzipping it and then unzipping the Macextras.zip again and overwriting files. This allows the application to start and download the update. Is there any way around this? Am I doing something wrong? Thanks for getting this working on the Mac, great job.
  5. dotequals

    dotequals Member

    Currently, yes, mono is supposed to crash after the download and before the update is supposed to start. On Mac and Linux the freeso.command and freeso3d.command scripts handle updating the client, so you just have to run them again after the crash.
  6. [7G] Wolfy

    [7G] Wolfy New Member

    is there any way to get a video to do this im not used to mac and im trying to help a friend
  7. JimGarb

    JimGarb New Member

    Hi Dot, thanks for the response. I do run the scripts again and I get into an update loop.
  8. dotequals

    dotequals Member

    Hmm, somebody else seems to be running into that here, but I haven't come across it. When you run freeso.command the second time does it have a bunch of text like "Inflating blah blah blah"? Did you close the terminal window with the crashed instance of mono before running it?
  9. Queenofthedelta

    Queenofthedelta New Member

    @JimGarb I was having the same problem on my girlfriend's mac. Haven't tried again since giving up, but have you had any luck yet?
  10. dotequals

    dotequals Member

    @JimGarb and @Queenofthedelta a screenshot or copy of the terminal output text after running ./freeso.command for the second time (after the game has downloaded the update and crashed once) would be helpful in figuring out this problem.

    If posting the info here, please take caution to edit out any personal info the terminal window might show such as your first and last name. Alternatively you can just send the output to me via DM on here or on Discord.
  11. JimGarb

    JimGarb New Member

    @dotequals Thanks for the response. I just went through the recent update semi-successfully. I've sent you a message in Discord on#support.

Share This Page