FSO.Patcher crashing while updating to version 64

Discussion in 'Support' started by Otis, Jan 21, 2018.

  1. Otis

    Otis New Member

    I recently downloaded and installed FSO, and everything seemed to work fine. I was able to launch the game and log-in where I get an Update Required popup saying The server you are connecting to requires version 64 of the beta/update branch to be installed (you currently have version 574 of the master branch). I click yes and the update file downloads and asks to restart the game. Once it closes I get an error message saying that FSO.Patcher has crashed. When I restart FSO launcher a popup says Game Auto-Recovered. FreeSO.exe was not present (most likely due to a failed update) and has been restored. I've tried multiple times and I get the same error. I've restarted my computer, launched the game as an administrator, launched the game in Windows 8 compatibility mode (I'm running Windows 10), and reinstalled both TSO and FSO, but nothing has worked. Is there a way to manually update?
  2. Otis

    Otis New Member

    Nevermind, just read on discord that the servers are getting hammered and to wait.
    Alonzo likes this.
  3. Pandora

    Pandora New Member

    now i need help on this...cant find info anywhere

Share This Page