I'm getting an error when I try to launch the game.

Discussion in 'Support' started by daleylife, Jan 6, 2017.

  1. daleylife

    daleylife Member

    I used the current installer from http://play.freeso.net/ and it said everything went fine, but, I get this error when attempting to launch:

    [​IMG]
    MarkM likes this.
  2. Crystal Atkins

    Crystal Atkins New Member

    I'm getting this as well!
    MarkM likes this.
  3. Howdy_Simmer

    Howdy_Simmer New Member

    And me :(
    MarkM likes this.
  4. Howdy_Simmer

    Howdy_Simmer New Member

    I got it working! You just need to change your compatibility mode to Windows XP (Service Pack 2) :) works.png WORKS 1.png
  5. daleylife

    daleylife Member

    Can a dev confirm this is a proper way to fix this error?
    I read somewhere else the game wasn't made for Win xp.

    EDIT: I tried changing to Windows XP compatibility mode and I still get the error.
  6. rafa010102

    rafa010102 New Member

    [quote = "Howdy_Simmer, post: 24144, membro: 3174"] Eu tenho que trabalhar! Você só precisa mudar seu modo de compatibilidade para o Windows XP (Service Pack 2)-benzóico. [attach = full] 2146 [/ attach] [attach = full] 2147 [/ attach] [/ quote]

    Eu fiz isso eo lançador ficou em branco e não começou
  7. The Architect

    The Architect Administrator Staff Member Moderator

    Don't run the installation from a protected directory, make sure it's run from downloads or desktop. Make sure to run it as administrator.

    FreeSO isn't supported on Windows XP.

    If you are NOT on Windows XP and are still experiencing this error after trying the above steps, please post more about your system.
  8. daleylife

    daleylife Member

    Okay. Originally, I had saved the installer in my main directory.
    But, just now, I re-installed (minus The Sims Online) while having the installer ran as admin and on the desktop and got the same error.
    Do I need to re-install The Sims Online as well?
    I have Windows 7 64-bit, 16 GB of Ram, and a GTX 760. The previous several builds worked perfectly for me.
  9. xXJDrocks450Xx

    xXJDrocks450Xx Well-Known Member

    Sorry for the late response!
    Why does this happen?
    The Sims Online is installed using 1114 cab files that are about a MB large. This means that certain important files to FreeSO are literally split and on multiple different cab files. The installer has to put all these files back together again. When you start an installation, the first few files it puts in the installation directory are split files. The reason why this exception happens is because one of those first few files was not completely extracted, meaning that there is missing information that FreeSO needs. This can happen because you start a TSO installation then immediately cancel it, or maybe the installer crashed towards the beginning of the installation. Either way, it's TSO files causing this, not FreeSO files.
    How can I fix it?
    Easy! You need to completely reinstall TSO using the installer (about 10 min. on faster speed internet). Once TSO is complete and it asks you to reinstall FreeSO, skip the FreeSO installation and move straight on to packingslips and OpenAL! (if you don't already have openal installed)

    Please let me know if you need further assistance.
    Tori Sim and The Architect like this.
  10. daleylife

    daleylife Member

    Okay, the game runs now. I get a login screen. Thanks, Jdrocks!

    Is this normal behavior now?
    Last edited: Jan 9, 2017
  11. Phade

    Phade New Member

    That was for open beta, but due to the overwhelming popularity, the servers crashed and they were forced to postpone and rethink how to go about the next phase.
  12. daleylife

    daleylife Member

    Yeah, I know, I was just making sure that coming to a login screen was the intended behavior.

    I got it now! Thanks everyone.
    Lannie likes this.
  13. Sparklings

    Sparklings New Member

    I don't get what you are saying I don't understand. So right now I am uninstall everything and I am going to re-install and see if this works but if this doesn't then can someone make a youtube video on how to download this for windows 10 or later because I am so confused!
  14. ChrystalRose

    ChrystalRose New Member

  15. daleylife

    daleylife Member

    I just wanted to add that I think the installer should tell you to be sure to unzip or unrar the files to the desktop and install from there.
    I just ran into this issue again for the latest build.

Share This Page