Installing FreeSO for iOS/Android

Discussion in 'Support' started by RHY3756547, Aug 23, 2016.

Thread Status:
Not open for further replies.
  1. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    It has an unusual resolution and I'm forcing integer scaling. This phone, by the current rules, is choosing 3x scaling. That's 600x3, or 1800 vertical resolution, which is greater than the phone's 1440. The current rules exist due to an edge (haha) case surrounding another fantastic samsung phone at 1080p for some reason, where the scaling is 2x and it cuts off the top and bottom of CAS a bit, but 1x is way too small. Man I love how android phones use really cool scaling.

    Your phone should probably be choosing 2x scaling. I'll fix it for the real builds.
    Tori Sim and JWofles like this.
  2. dennusz1995

    dennusz1995 Active Member

    unfortunately. rhys doesnt have an edge device.
  3. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    The game is still hard to launch, even more so that the current version does not display any errors and I can't exactly switch back from the branch I'm currently working on. All I can say with no error reporting is that you either did "something" wrong or that there's an issue with your GPU.
  4. Tori Sim

    Tori Sim Active Member

    Well, I read the instructions 3 times, and followed step by step, everything went flawlessly installing it to my phone, but it is in fact the "edge" part that keeps me from being able to press to edit my sim name and press numbers for next page of clothes ... I believe that if my phone had a normal screen it would not be this way... I may need to get my Tablet screen fixed to play this :p:D
  5. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I was replying to someone who deleted their post for some reason. Your issue is still just a misconfiguration with the app.
    Tori Sim likes this.
  6. I was dead since March, and when I come back I find this thread.

    Whoa, maybe my dreams of playing The Sims 1 (not really The Sims 1 but...) on my Android phone (I doubt my Moto G Turbo will run it flawlessy tho :p ) will finally be real?

    Awesome job @RHY3756547, thanks for porting FreeSO to Android, will test it as soon as possible. :)
    RHY3756547 likes this.
  7. Fraczek20

    Fraczek20 Member

    I've installed it on my Samsung Galaxy S5 neo and It's very slow (to the point where system interface responds slowly) but works. Took me one and half hour to install and then five minutes to load up and connect to the server. Despite low fps It's not so bad but It would be better if I could scroll the screen via touchscreen.

    PS: Where are TSO files stored on my phone by the way?
  8. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Guys, remember that freeso.ml isn't exactly the performance benchmark we're going for. There are also currently a few issues with android as Xamarin.Android doesn't support AOT compilation for some obscure reason.

    @Fraczek20 In the app's local storage, wherever that is.
  9. Marvin732

    Marvin732 Active Member

    I have 24/7 0FPS ingame, loading to the CAS is taking years , i have the S5 Neo too
  10. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Try restarting the app. For some reason the Xamarin versions decide not to switch screen occasionally.
  11. Mindyvolt

    Mindyvolt Member

    i am gettin mad, i typed it in and still no
  12. @RHY3756547 I found a small issue with the Android version: If you download the APK, go to the main screen (where you insert the IP) and close the app, you can't do the process to download the files, because, if you open the app again and try to being the process, the app crashes.

    Anyway, finally got the FreeSO to start downloading the TSO files, will reply after I get FreeSO working :)

    EDIT: And now it is stuck on "Extracting TSO Files... (TSOClient/avatardata/animations/animations.dat,512)"
    Last edited: Oct 12, 2016
  13. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    It's not stuck, you're just impatient.
  14. :(

    I don't know, how long it should take in that step? (the TSOClient/avatardata/animations/animations.dat), because the others one were quick to finish, but this is taking more than 15 minutes to extract.

    EDIT: Okay... It is extratcting veeeeery slowly.
    Last edited: Oct 12, 2016
    JWofles likes this.
  15. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    That number after it should not be 512. There is something wrong with the storage media you are using, or your version of androis has a really screwed implemention of java.zip.
  16. I'm running the Stock ROM, so maybe Motorola/Lenovo fucked up. (And I tried using the internal and the SD card)

    Anyway, after waiting 2 hours to extract, it finally finished.

    The CAS isn't laggy and the map view is a bit laggy (maybe at 25fps?), however gameplay is laggy (the empty_map.xml is... playable but the nightclub simply dropped the FPS to 1)

    Well, it works! A bit laggy but it works!
  17. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I can imagine some android phones having a serious issue with RAM/VRAM usage. Right now only the high end really support what the renderer is doing.
  18. SophiaBaby

    SophiaBaby Member

    Has anyone been able to get this to work on a non jail broken iPhone?
  19. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    It probably won't work right now unless you manually resign with xcode.
  20. Autumnrose

    Autumnrose New Member

    Can some one direct me where to go to get the game on my phone? I have a samsung J7 it should work but I just need the directions on how to install it when its not downloaded from playstore.
Thread Status:
Not open for further replies.

Share This Page