[LEGACY]How to join a server and install FreeSO

Discussion in 'Support' started by Nahuel3d, Aug 5, 2015.

  1. dvdmcwilliams

    dvdmcwilliams New Member

    Hi, i discovered this today, im so exited, yay!! :D, but one problem, when im installing the game, it says i need a sims online account, i don't have one, i tried to make one, but i couldn't, so i press cancel, then the installation closes, and the same again, what i got to do?:confused:
    Edit: problem solved, i got another one, when i launch FreeSO.exe i have the next "error":

    Last edited: Mar 27, 2016
  2. JWofles

    JWofles Active Member

    Wait is this after you've installed it or are you launching TSO.exe?
  3. dvdmcwilliams

    dvdmcwilliams New Member

    Thanks to answer i've edit the post, with a new problem!!
  4. Well, the error shows your problem. "Try updating your graphics drivers."

    So... try updating your graphic drivers! If it is already on the latest version... well, you can't use FreeSO unless you upgrade your graphic card... :/
  5. dvdmcwilliams

    dvdmcwilliams New Member

    Thanks that was the problem, but now there's another...
    FreeSO.exe has stopped working:
    [[[Problem signature:
    Problem Event Name: BEX
    Application Name: FreeSO.exe
    Application Version:
    Application Timestamp: 56f6a85d
    Fault Module Name: StackHash_0a9e
    Fault Module Version:
    Fault Module Timestamp: 00000000
    Exception Offset: 00000000
    Exception Code: c0000005
    Exception Data: 00000008
    OS Version: 6.1.7601.
    Locale ID: 11274
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789]]]

    what could it be :confused:

    Edit:!!! :D seems to be fixed after command line with -dx11 as i read in the forum, and select compatibility with winxp sp3 and run as administrator.
    JWofles and MrPowerGamerBR like this.
  6. Sara

    Sara New Member

    How do I download the latest FreeSO dist?
  7. JWofles

    JWofles Active Member

  8. Nickst3r15

    Nickst3r15 New Member

    Hi I have followed the instructions to the Tee and eveytime when I click on the free so.exe it force stops it self so basically it crashes can someone please help me thanks
  9. Dominiksim

    Dominiksim New Member

    I have this error. How to fix this?

    Attached Files:

  10. Dominiksim

    Dominiksim New Member

    And i have this on every face..

    Attached Files:

  11. Alvar

    Alvar New Member

    It looks EXACTLY the same here. I've updated Graphic drivers, installed XNA, OpenAL (funny, because installing it... it's less than a second), still doesn't work. Is there anything more I can do? Or this just means "leave it, your notebook is too old" :<
    Dominiksim likes this.
  12. "leave it, your notebook is too old"

    Try switching the renderer to DX11, here's how (I wrote that for another thread):
    The most "common" one:

    Your graphics card is outdated and doesn't support/has every feature from OpenGL, this causes an blank screen after opening it.

    First, try updating your graphics card drivers, after updating, try running FreeSO again... did it work? Congratulations and have fun!

    Didn't work? Well, there is another way to make it work...

    Create a shortcut to "FreeSO.exe" by right clicking the executable -> Send to... -> Desktop
    Now, find the shortcut on your desktop, right click and click on "Properties", a window will open...
    Are you seeing the "Target" text? Well, after the ", add -dx11:
    Try running FreeSO with your desktop shortcut you created.

    But, if your graphics card is too old, maybe it won't work even if you switch to DX11 (That's what happens in my very old PC (I don't use it, but I wanted to install FreeSO on it to test networking)), but hey! just try ;)
    Alvar likes this.
  13. Sel

    Sel New Member

    So my friend got this error when trying to launch FreeSO

    It's weird because the uigraphics file is in place and the program still can't find it. Any tips?
  14. Did you extract this ( https://dl.dropboxusercontent.com/u/12239448/packingslips.rar ) into the TSOClient/packingslips folder? If not, do that ;)
  15. Sel

    Sel New Member

    yes i did. the uigraphics file is in place, i even sent her my own packingslips folder and it still doesnt work
  16. Try running FreeSO in Administrator Mode (right click + run as administrator), maybe that's not the solution, but hey, it is worth trying :)
  17. Sel

    Sel New Member

    Tried that too, still no luck
  18. So, is your (actually your friend) packingslips like this?
    And it is not a subfolder, right? It must be a folder in the TSOClient folder.

    If it is everything right, then I don't know, is The Sims Online installed in "C:\Program Files\The Sims Online"?
  19. Sel

    Sel New Member

    We managed to fix it somehow, but now this happens
  20. Try installing OpenAL ( https://www.openal.org/downloads/oalinst.zip ) and then running FreeSO again.

    If that didn't work, try updating the graphics card driver.

    If updating the graphics card driver didn't work, change the FreeSO renderer to DirectX 11, here's how: http://forum.freeso.org/threads/how-to-join-a-server-and-install-freeso.676/page-19#post-18285

    If changing the renderer also didn't work... well, there's not too much you can do :(

Share This Page