[LEGACY]How to join a server and install FreeSO

Discussion in 'Support' started by Nahuel3d, Aug 5, 2015.

  1. dd33x12

    dd33x12 New Member

    I installed the game and extracted the files to the correct locations running as admin with windows 98 sp2 comp.. installed openal drivers all up to date and system is beyond capable of running the game but it isnt working. When I run Freeso.exe nothing at all happens no error msgs nothing .. I check processes and see 3 freeso.exe processes running that I cannot end. Not sure what to do but any help is appreciated
  2. Nahuel3d

    Nahuel3d Active Member

    I'm not really sure about this, but we're in middle 2016. Windows 98 is obsolete.
    FreeSO is being made with today's PCs in mind, it's not running on the same engine as The Sims Online(it's getting completely rewritten!). I'm really sorry but i think the only solution to your problem is upgrading to a newer Operating System.
    Tirea likes this.
  3. NathanR23

    NathanR23 New Member

    I'm getting the same error how did you get it to work?
  4. Clonest

    Clonest Active Member

    Annnd updates later and my mine still has no sound. It stopped working somewhere after the first May update release.
  5. LittleLifeSaver

    LittleLifeSaver New Member

    Hi i'm new. Hopefully i'm posting on the right thread. So, i'm kinda lost.. When i open FreeSO.exe i get this error: [​IMG] Am i doing doing it wrong or skipping something? I have no idea :rolleyes:
  6. dd33x12

    dd33x12 New Member

    Lol I meant I tried running the game in windows xp sp2 compatibility mode after it didnt work in my normal windows 7 (im not using A windows 98 pc lol).. The game simply wont launch for me but it does create 3 processes that cannot be stopped without a reboot. idk what to do all instructions followed correctly
  7. lil cher

    lil cher New Member

    so I have everything done the way you said but when I try to open it I get the message this is not a valid win32 application did I do something wrong
  8. LetsRaceBwoi

    LetsRaceBwoi Well-Known Member

    Your GPU doesn't support the newer versions of OpenGL. Try the "-dx" flag and see if that works for you.
  9. Nahuel3d

    Nahuel3d Active Member

    Oh, haha, i can't help you there. That's really weird.
  10. Annabelle

    Annabelle New Member

    I am having the same problem :[
  11. Nahuel3d

    Nahuel3d Active Member

    LetsRaceBwoi likes this.
  12. Jowiko96

    Jowiko96 New Member

    I keep getting the "property data received, entering property" notification but then it just stops and sits at a standstill. Any reason why?
  13. Goomba

    Goomba New Member

    Hi, I installed it on Ubuntu 16.04 and I'm getting the following when running FreeSo.exe
    [​IMG]
    I downloaded the setup files on a Windows machine, then transfer them to ubuntu, installed SO with wine, and lunched FreeSO.exe with mono.
  14. Annabelle

    Annabelle New Member

    I'm sorry, I'm not techie at all :( what is "-dx" flag
  15. mattnotley2004

    mattnotley2004 New Member

    DX flag is what is circled in the screenshot below. It tells the game to run in DirectX mode rather than OpenGL.
    Create a shortcut on your desktop to FreeSO.exe, right click on the shortcut and open Properties.
    At the end of the Target box, add a space followed by -dx
    Click Apply. Then run the game using the shortcut.
    dxflag.png
    Annabelle likes this.
  16. Annabelle

    Annabelle New Member

    This fixed everything! Thanks!!!
  17. Becca

    Becca New Member

    For some reason, I cannot find where my TSO installed. I ran the .exe provided in the main thread and installed it. It didn't ask me where I should install it, though I assumed it'd be Drive C as that's where I install all my games. Also after the installation finished, it didn't ask me about a serial code as described in the original thread. I can't seem to find it anywhere, and it takes a while for it to install so I really don't want to keep re-installing it if I don't know if it'll work. I've searched my computer and it can't seem to find anything other than the .exe used to install the game. It's as if it didn't install, but I did run the installer etc.

    tl;dr
    The Sims Online doesn't appear to be installing on my computer, at all, despite the fact I run the setup.exe as I should, and I'm installing it on Drive C. This isn't the first time I have installed it on my PC, and I know it worked the last time. What am I doing wrong?
    Last edited: Jul 6, 2016
  18. wiltors42

    wiltors42 New Member

    Is it not installing to /program files/maxis?
  19. TheMarshmallowBear

    TheMarshmallowBear Active Member

    Are you installing the game or downloading the game?

    The download takes ages because EA

    While the install typically install TSo to C:/Program Files/Maxis/The Sims Online

    note that the Program Files folder is DIFFERENT to Program Files(x86) folder. As there's two on our computer.
    wiltors42 likes this.
  20. Becca

    Becca New Member

    I click http://largedownloads.ea.com/pub/misc/tso/Setup The Sims Online.exe and run the .exe when that file has downloaded, it starts the setup thing and it completes. I've looked in both program files and program files(x86), it's in neither. I'm not entirely sure what I'm doing wrong, but I'm following the instructions as I should, it's simply not installing to my drive.

    This is what I get when I run the .exe, thinking this is installing the game to my PC despite the fact it never asked where to install it;

    https://gyazo.com/f04e0e9f39e2e0eae3b8e267d2dd1512

Share This Page