[LEGACY]How to join a server and install FreeSO

Discussion in 'Support' started by Nahuel3d, Aug 5, 2015.

  1. xXJDrocks450Xx

    xXJDrocks450Xx Well-Known Member

    Sorry if I don't quite understand your problem, if by new installer you mean mine- and by the error that is the case- I haven't made an uninstalling freeso step, meaning that a program removing packingslips shouldn't be there.
    The best advice I can give you is running this program I made here. It automatically senses what programs you still need to install. Simply skip the TSO, and FreeSO installations when it asks you if you want to install them. When you get to the packingslips setup step, it will automatically put everything where it needs to be.
    What most likely happened was, there was an error where it couldn't delete the file C# said was in the packingslips directory for some reason, and couldn't find it. I will investigate the problem further, but following the instructions above is the easiest way to fix your issue. If that fails then I will certainly help you further :D
  2. Mr X

    Mr X New Member

    I can't get freeso to work, either. Recently, I had to format my hard drive and reinstall windows. I was able to reinstall all my other programs except for freeso. I backed up my old version and it will run alright and i can play in my own house, but i cant connect to servers because the servers aren't running the same version that i have backed up. But, when i use the launcher, or even when i install freeso manually the using dist373 and packingslips, freeso will not run at all. If i try to run it without having installed the launcher, it just won't start and i get no error to tell me anything, i just get nothing. When I try to run it with the launcher, it will tell me that freeso has crashed and must close, but that's it. I don't know how to tell which dist# i am running that works on my laptop, but it's not the current one, so I am doomed to play in my own house and never connect to servers for now. I could before tho when my backed up version was current for the server. Something isn't working on the current version for me. It just won't go. I've been at it for two whole days now trying different things, but nothing works except for my backed up version that won't allow me to connect to servers.
  3. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Replace your working copy of freeso with the files from http://servo.freeso.org . (artifacts => dist 373.zip) Either the launcher is not working or something is not installed correctly. (likely TSO registry entries going by what you said earlier about it not working when being separate from TSO)
  4. Mr X

    Mr X New Member

    Thank you. I did try that earlier, but i just tried it again to be sure, but I got the same results. Not sure what to make of this one. Would freeso.exe need to be adjusted for winXP compatibility? I'm using win7 pro. I also noticed that when i do the manual installation as listed in "Installing FreeSO" instructions on page one of this thread, everything is in the tso client folder and there is not a separate folder for freeso unless i use the launcher to install everything at once. Then they are separate. Either way tho, it's not working unless I run the backed up version.
  5. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I'm not going to be sure what the issue is without an error report, which I can't possibly get til global server launches or I have some way to modify the older game versions at all.
  6. Mr X

    Mr X New Member

    I understand. I've waited years for tso and I can wait a bit longer. :) I will just have to keep an eye out for when it becomes possible. Thank you for all your replies and advice. I do appreciate it very much.
  7. claradex3328

    claradex3328 New Member


    I have just joined the forum. I am so excited that this is coming back so thank you to the people behind the scenes who working hard to bring this back. I played TSo for years and can't wait, however I am having some issues with getting the game to work :(

    Please could someone help?

    I have followed all of the steps for installing the game from the first initial post on this thread, using the links and instructions to place certain files in certain folders, however I do not know what to do next. If i access the game normally it still asks me to log in with ea.com details, and I can't see a freeso.exe file anywhere to be able to enter that way.

    Sorry if I am being dumb but if anyone could help with would be greatly appreciated and I look forward to joining you all online soon and getting to know you!
  8. simsfreak

    simsfreak Active Member

    There are two ways to do it the normal way in which u need download and install The Sims Online. Then extract the latest dist 380 I think and packingslip. There is also all in one. Created by JD it will install all u need and set up a shortcut on ur desktop u click there thats it
  9. Noeltarifi

    Noeltarifi Member

    hello, how do i install this so i can play when it goes live. i see the all in one installer, is that the current way to install? and can someone walk me through it?
  10. simsfreak

    simsfreak Active Member

    We have to wait until the announcement. Just sit tight and stay tuned.
  11. Raeven

    Raeven Well-Known Member

    This wasn't announced here but in the Facebook group it was - the all in one installed found at play.freeso.net is the way to install but playing on the Global Server wont actually be an option until Open Beta starts on Jan 6th, 10pm GMT. Here's a link to a time zone converter to find out when that is for you:
    Hrmmm. I dunno if the link will show you that time and date. You might have to set the day (2017/01/06) and time (22:00) yourself.

    There is currently no place to register a username and password for playing, but they'll post a link for that. We might even be able to register the day before. Maybe.

    @Tori Sim posted instructions for using the installer in the FB Group
    https://www.facebook.com/notes/1630393313843251/All-in-One Game Install/1800279790187935/
    And also made a couple of videos of doing so which is quite nice for anyone still feeling a bit uncertain. It looks pretty straightforward so .. YAY!
    Last edited: Jan 4, 2017
    DarkRaven574 and Tori Sim like this.
  12. Tori Sim

    Tori Sim Active Member

    I'm sure I will need to update the videos after the next open beta launch ^_^
    DarkRaven574 likes this.
  13. Morrg

    Morrg New Member

  14. dink

    dink New Member

    quick question from someone completely out of the loop.
    as for now, is it possible at all to log on? i've seen gameplay on youtube titled to be from january 9. so obviously with the news of the closed beta coming up thats a bit confusing.
  15. Becky with the good hair

    Becky with the good hair Administrator Staff Member Moderator

    FreeSO release had to be delayed due to immense traffic to the servers. There will be an invite-only beta coming to handle all the traffic in a better, less intense way.

    For more information, check out this blog post: http://freeso.org/plans-for-the-future-additional-preparation-and-invite-beta/
  16. derangedjags

    derangedjags New Member

    Anyone able to help. I went to the main site and download there installer did everything. Game load up but keep trying to go to ea server I wanna play on one of the community servers. Give me a login screen but just goes to ea server.
  17. Raeven

    Raeven Well-Known Member

    You need to use the Legacy installer. I am not sure why the installer for the broken game is still linked up. That is confusing.
  18. simsuncensored

    simsuncensored New Member

    I am having trouble installing the game. Can anyone help?
    I have Installed the game using the installer and manually.
    I Installed OpenGL and OpenAL and NET Framework
    I updated my Drivers and installed The Microsoft Visual C++ for 32bit
    I got nothing but error until I change Target added -dx11 then it loaded the game to the page that you make your sim. then pops up with this error below.
    I have a labtop
    Windows 7 Ultimate service pack 1
    Processor Intel(R) Dual CPU T2370 1.73GHz
    Ram 2.50 GB
    32-bit Operating system
    can someone please help?

    Attached Files:

  19. DarkRaven574

    DarkRaven574 New Member

  20. simsuncensored

    simsuncensored New Member

    I read the instructions..
    I did notice something watching the video...
    My game loads right too The Sims Online page and then"the making a sim page" It skips the rest.(No load box)
    Last edited: Jan 15, 2017

Share This Page