Minor Bug Thread

Discussion in 'Support' started by bennerman, Dec 17, 2015.

  1. Should we still use this thread to talk about minor bugs? If yes...

    1. (I don't know if TSO had this feature, I never played TSO, but I spent most of my time playing The Sims 1)

    I noticed that using < and > doesn't rotate the object, as I said, I don't know if in TSO using those keys would rotate the object, if not, it would still be a nice addition to FreeSO ;)

    2. Also, FreeSO isn't using the system keyboard layout, if I press "Ç" on my keyboard, ":" will be written into the text box, this doesn't happen in other applications.

    3. You can still scroll with Right Click even if a pie menu is open, again, maybe that's a TSO feature and I didn't know, but, in The Sims 1, you can't scroll while a pie menu is open (it doesn't do anything at all in The Sims 1, just closes the pie menu after you release right click)

    Maybe those issues are known, but I thought it would be nice reporting it here :)
  2. Mr X

    Mr X New Member

    Hello, i updated the dist and logged on today for the first time in a few months. When i go to buy mode, everything is red and i can't buy anything. When i light the fire place, the striking match sound plays over and over as well as the vocal, ahhhhhhhh. When he puts dishes in the dishwasher he groans and sighs over and over. it's kinda funny. But the not being able to buy stuff is kind of... limiting. Same for build mode. Can't build. It wants me to have money to build and buy. Was that recently added? Time to get a job?
  3. TheMarshmallowBear

    TheMarshmallowBear Active Member

    * It's red because you have no money, we don't have a global server and there's no "Starting money". If you need quick money click ont he ground and press "Request Fund" then enter the amount.

    * both Fireplace and Dishwasher are known issues. Fireplace I don't think stops but Dishwasher stops after a while, if you want your stop to stop groaning just interact iwth another sim (hug is the best one, not sure if it matters)
  4. Mr X

    Mr X New Member

    Ah ok. When i built my house money wasn't an issue. Everything was just zero dollars. Very cool to see new things happening with this!
  5. emrae

    emrae New Member

    I can't see my character in character creation and I can't see her head when I click things in game.

    [​IMG]
  6. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Disable "Antialiasing" in game options. (ingame)
    Blayer98 and emrae like this.
  7. emrae

    emrae New Member

    Thanks for your help!
  8. I don't know if this would be considered minor (I personally do, since it doesn't affect gameplay.) but I've got no sound coming from the game at all. No music, no clicks and dings, nothing. My drivers are up to date and I have OpenAL installed. Volume levels are normal, both ingame and out as well.

    As I said, this doesn't affect my gameplay experience at all, so I'm in no hurry. I just thought I'd report it just for the sake of reporting bugs. :)
  9. Fraczek20

    Fraczek20 Member

    Interesting. I had a similar problem on my laptop and for some reason OpenAL was not installed correctly. Did you tried reinstalling it?
  10. Indeed, several times in fact.
    I think I'm going to reinstall TSO's files and see if maybe something went wrong there.

    EDIT: Reinstall did not work. Checked soundcard settings, everything in functioning order. No surround sound or any weird configurations.

    EDIT 2: Haven't been around in awhile, but the issue seems to be fixed. Just installed the latest version and the sound is working fine now.
    Last edited: Aug 18, 2016
  11. Becky with the good hair

    Becky with the good hair Administrator Staff Member Moderator

    [​IMG]

    Wrong hair and skin color
  12. Fraczek20

    Fraczek20 Member

    Can you post how your sim is supposed to look like?
    Tori Sim likes this.
  13. TheMarshmallowBear

    TheMarshmallowBear Active Member

    Pie Menu refuses to acknowledge skin-tones, and defaults to white.
    jimla likes this.
  14. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Hair is actually directly related to skin colour for some heads. It's not being copied correctly from the sim yet.
    jimla likes this.
  15. Raeven

    Raeven Active Member

    Hi - very new having just spent the past few days trying to acclimate and map everything out. (Lot's of "WOW!!"s, obviously, but saving those for another time and thread.)
    Two questions -
    First is would there be a separate thread for minor bugs in objects?
    During 'acclimation and mapping out' those are pretty much the only things I can jot down and they're so low priority that adding them to a gameplay oriented bug reporting thread would just clutter it up. Examples - I fixed the (strictly graphical) glitch in sinks that left soap suds after washing dishes. And more functional but still very low priority ones such as the DJ booth refusing to turn off after my Sim has DJ'd. Is this the level of thing meant for this thread? And if so, should I also be jotting down the solution (or uploading the patch itself) here when I do know it?

    Second, is there a Known Bugs List posted somewhere?
    Most things on little list seems to be either SLOT related (pets disappearing (dropping below the world I think?) when using pet beds, for example) so nothing to be done with any of that yet, very possibly user error *cough* or not (assuming lights were not auto turning on because I expected them to work differently) , or seems like something that is currently under development (surrounding an area with pool creates a windowless room so daylight does not enter it) so, like the SLOT stuff, reporting it would just be useless noise right now. I was looking to check that sort of stuff against a known bugs list.
  16. Raeven

    Raeven Active Member

    In Volcanic's BHAV tree editor, I can "get" and "adjust" Relationship, but cannot "Set" relationship (it pops back to "get")
  17. RayneCroft

    RayneCroft New Member

    Greetings, i am new to the forum so sorry if i make mistakes, i am very proud of this project and i would love to help as much as i can...
    So as a tester i will try to write down what i see.
    I havent tested much but there are some strange things happening:

    When i light the fireplace for example, there is a light sound and a male moaning sound that gets stucked and it gets really pestering;
    The DJ cabin, once i turned it on i wasnt able to turn it off, when clicking turn off it just changed to the next song.
  18. Raeven

    Raeven Active Member

    Hi, Raynecroft :)
    As I understand it, the moaning sound in the fireplace is a side effect of the way the sound files are currently understood by FreeSo. It is a temporary situation. A patch has been made to eliminate the effect in the meantime. You can find that in the objects forums along with patches for a few other objects with looping sounds:
    http://forum.freeso.org/threads/patch-looping-sounds.2013/

    There is also a patch for the DJ Booth, but it only fixes the on/off problem and still wont allow you to use the 'Next Song' interaction.
    http://forum.freeso.org/threads/dj-booth-temporary-patch-turn-on-off.1995/
    The DJ Booth's bug is due to the way FreeSO currently understands "events" in animation files and, like the looping sound issue, is a temporary situation.
    This same bug effects washing dishes in sinks (leaving soap suds in the sink). You can clear the suds by washing hands or use this patch
    http://forum.freeso.org/threads/sinks-patch-wash-dishes-graphics-glitch.1992/
  19. RayneCroft

    RayneCroft New Member

    Thank you so muuuuuch <3
  20. daleylife

    daleylife Member

    Played a bit today, here's what I noticed (I apologize if these are known.):

    1. In Build mode, the right CTRL button is not set to work, so deleting walls is not doable. Only the left CTRL functions.
    I'm left handed (using the mouse), so using the CTRL on the right would work much better for me. The right SHIFT doen't work either.

    2. Somehow I got added to the robot factory job and my Sim automatically ran to the car, before it disappeared.

    3. I'm playing on the freeso.ml server. There's a Servo there who also got added to the robot factory job. Now, he is low on motives but he won't do anything but whine while showing the negative speech balloons.

    4. The NPCs aren't always working correctly. The gardener likes to water the same plant over and over; I logged in just a bit ago and there were three maids on the lot just stuck, not moving. One was doing the walking animation, but staying in place.
    Last edited: Dec 24, 2016

Share This Page