[Task 5] Create an Object entirely from scratch

Discussion in 'Evaluation' started by RHY3756547, Mar 13, 2016.

  1. TheMarshmallowBear

    TheMarshmallowBear Active Member

    I had the same issue with sprites, I even loaded my Meditation Mat and the thing once again disappeared in the object viewer and I had to somehow re-do the object graphics :/
  2. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Do you mean "changes did not appear in the object thumbnail"? Because there's no reason sprites should ever disappear.
  3. TheMarshmallowBear

    TheMarshmallowBear Active Member

    I really don't know. The chunk ID has the sprites and the drawgroup had a different sprite, yet when I switche dthe tab to the general Object Viewer (the one that has the functionalities of which room to place it, lot category etc,) the object viewer displayed "no" sprites at all

    Altough that may have been because the drawgroup had an id of 1 instead of 0. So *shrug*
  4. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    It's just not updating the graphic. It will be fixed before the final build.
  5. Tirea

    Tirea Active Member

    Okay now I feel stupid...
    I actually don't know why I didn't see that I made them return false. I know those should loop back to themselves. Guess that's what happens when you are in a hurry and decide to create something... ^^

    Really a bummer that we can't use them! I loved the objects that came with Magin' Magic! Even the cool spell animations work pretty much flawlessly in FSO (I used the heart effect from the marry me spell in a mod for the fridge where you'd give the fridge a kiss, the heart effect starts and a wedding cake would spawn! :p)

    Those crashes are super weird! I "tested" this a little bit to see what's the cause of this and it seems that editing a chunk inside the iff more than once is what crashes the IDE.
    For example: I'm working on an objects, change it's function to include some funny animation, save the file, test it and decide to change the animation, I can edit the function and change the animation just fine, but when I try to save the iff a blank window pops up for a split second the the "FSO.IDE isn't working anymore" pops up and it just crashes.

    I decided to install a fresh copy of TSO and FSO and so far the crashes are gone. Maybe my installation had some errors...
    Raeven likes this.
  6. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Might have been an old build... and it didn't provide a stack trace?
  7. Tirea

    Tirea Active Member

    No, it just opens a window for a second and then crashes, nothing else.

Share This Page