[Temporary] Run official FreeSO on Mac using wine (Linux coming - Feedback needed)

Discussion in 'Support' started by Poogly, Jan 3, 2017.

  1. Poogly

    Poogly New Member

    Hi FreeSO enthousiast!

    FreeSO is a active project supported by our fantastic Rhys! Unfortunatly, developing FreeSO is an heavy task with multiple priorities. Even if Mac and linux systems will be supported in the future you might want to play FreeSO before we figure out a way to deliver your an official and user-friendly build for your favorite operating system.

    This is why we have this tutorial to explian how to get FreeSO running on Mac or linux using wine. Wine Is Not an Emulator but it can run windows binaries on non-windows systems!

    The linux part is not ready yet, but, it will be almost the same as the Mac one.

    FreeSO on Mac with wine
    In order get things easier, we will use PlayOnMac, a super tool that makes wine easy.
    You will find PlayOnMac here: https://www.playonmac.com/
    Installation is easy, just download PlayOnMac and copy the application into your Application folder.
    Download the vcredist from Microsoft, it will be needed: https://www.microsoft.com/en-us/download/details.aspx?id=5555
    Also you will need JDRocks installer: https://www.dropbox.com/s/6q8m9voxduthvuy/FreeSO Setup x86 Edition.zip?dl=0

    Launch PlayOnMac and click on the "Install" button. A new window appears then click "Install an unsupported program"
    Hit Next... next... next...
    At some point the assistant will ask you what you want to do, choose "Install a program in a new virtual disk", then hit Next
    Enter the name of the program : "FreeSO" then hit Next
    The assistant will ask your for pre-setup task, choose "Install some libraries", hit Next
    In the long list check "POL_Install_dotnet45, then hit next
    Then wait and hit next when needed.
    At the end the assistant will ask you for a file to execute, choose the vcredist file from microsoft and follow the installer.
    After the setup is finished, end the assistant.
    In the main PlayOnMac window choose "Configure" button
    Then on the left panel choose "FreeSO", and go into "Others" and click on "Run an .exe into the virtual drive" then select the FreeSO installer.
    Follow the steps from the FreeSO installer. After the installer is finished do not ask for a shortcut on the desktop.
    Go back into the configuration screen, select "FreeSO" and "General" tab. Then click on "Create a new shortcut from the virtual drive", wait for the new window and add FreeSO.exe as a shortcut.
    Now FreeSO should be available in the main PlayOnMac window, select it and click on "Execute"

    You may experience an error with texture.xml thing. If it's the case, go in the main PlayOnMac window, select FreeSO, on the left panel choose "Open directory". A new window will appear with FreeSO folder inside go to the parent folder, there is files under "The Sims Online/TSOClient/packingslips". Copy these files into the packingslips directory of the true TSO install located into the "Program Files/Maxis/The Sims Online/TSOClient/packingslips" folder few directories above.

    You will have trouble with skins that won't appear properly, we will figure out something, meanwhile have fun!

    Please give us some feedback to improve this tutorial before I add screenshots and everything, thanks!
    Hayran and JWofles like this.
  2. SophiaBaby

    SophiaBaby Member

    Is this for the new version that is being released tomorrow? Like do I have to add anything else
  3. Poogly

    Poogly New Member

    It is for both of them.
  4. Seananthony

    Seananthony New Member

    Do you have any fixes for this "error ! Files mismatch" issue? Overtime I'm going to install the POL_dotnet45 this message comes up and I can not continue.

    Attached Files:

    jimla likes this.
  5. JWofles

    JWofles Active Member

    I'm getting the same error :(
  6. Altariah

    Altariah New Member

    I've had this too !
    I canceled the whole thing and tried again, and it worked somehow...
    But then I have an issue right after the POL_dotnet thing.
    It can't seem to install .NET Framework 2.0 . It takes forever...
  7. jimla

    jimla Member

    Has anyone else been able to get past this? I tried Altariah's solution to cancel & retry with no luck. It looks like the bug has been reported to PlayOnMac, but there hasn't been any activity on the ticket yet.
  8. BelleRae

    BelleRae New Member

    Ran into the same issue with PlayOnLinux using this method. I switched to a more powerful computer and was able to get past this part (even though the internet connection was significantly slower?) in about 5 minutes. I got all the way to the FreeSO Installer (the link in the beginning of this post is broken, so I downloaded the .zip from freeso.net and extracted the file into my "freeSO" folder in the Documents directory, and replaced the given installer with "FreeSO Installer.exe"). It went okay, but shortly after clicking install, wine crashes and spits out this report: (See Attached)

    Attached Files:

  9. MamaPickle

    MamaPickle New Member

    I can't get past the Win32 Registry Error. I click "Search and repair" and I click on "Apply" and it says ".NET cannot be updated because this version of windows isn't upgradable" (Or something very similar).
  10. Nickie

    Nickie New Member

    Does this work for anyone at all? Why would this thread be made if it didnt?
  11. jimla

    jimla Member

    As an alternative method I tried to install using wine & winetricks, and I'm stuck on this exception...I'll keep ya'll posted if I make any progress.

    Full Exception Info: System.IO.IOException: The process cannot access the file 'Z:\Users\[USER]\.wine32\FreeSO-1-28-17a 2\MSZipTemp\Data1.cab' because it is being used by another process.
    at OfficialFSOInstaller.Form1.TSOCabExtractor()
    at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart()
  12. Cdash

    Cdash New Member

    I am not really Linux Savy, but I do have Linux Mint distro installed on a separate partition. If I can be of help "Testing" let me know.
  13. Tepiloxtl

    Tepiloxtl New Member

    I figured out how to run FreeSO on wine. Unfortunately, it's not very elegant, runs on few hacks and workarounds and... well, it's stable... assuming you'll be able to connect to server and join a lot. I'll do a write up on it tommorow...
    mrpenguinb and jimla like this.

Share This Page