Tried to make game Full Screen, now everything is messed up.

Discussion in 'Support' started by daleylife, Mar 31, 2016.

  1. daleylife

    daleylife Member

    I added 1204x1200 f or something similar to the FREESO shortcut. It din't look right to me, so I simply deleted the # and f from the shortcut. But, now, the game still goes full screen, but UI is off center and everything. How can I just make it windowed like before?

    EDIT: I have now done a complete re-install of TSO,restarted computer, re-extracted FreeSo files and packing slips and game is still messed up.

    Images of how my game looks:

    [​IMG]
    Game starts up and is forced to far left and 'windowed." ^
    [​IMG]
    Actual in-world game looks "okay", but UI is not where it should be, and I get screen tear. ^
    Last edited: Mar 31, 2016
  2. daleylife

    daleylife Member

    Tagging @RHY3756547 just in case this somehow is specific to the game and not computer settings. I'm not really sure though.
  3. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Try the argument "1024x768 w". Not sure why it is setting the resolution but not telling the game.
  4. FalseZen

    FalseZen New Member

    Have you tried the method where you edit the FreeSO.exe.config file?

    If you don't know how:
    Right click on it, and rename the end of the file to FreeSO.exe.config.txt
    Then read this page: http://forum.freeso.org/threads/how-to-fullscreen.1022/#post-16276

    Be sure to set the "<setting name="Windowed" serializeAs="String">< value>True</value>< /setting> to "False". Save, exit, and take the ".txt" off the file name.
  5. daleylife

    daleylife Member

    Thank you for your replies... I re-installed this morning and the game was its normally windowed self. Maybe the fact my computer hadn't been shut down was the culprit? I'm not sure, but I'm just leaving it as is for now. And @FalseZen, when I was experiencing the issue I did directly edit the settings in the config file. The game was ignoring any edits to that and 'codes' added to the shortcuts. I'd never experienced any bug like that before.
  6. emrae

    emrae New Member

    This is happening to me, is there a fix?
  7. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    Fullscreen currently does not work correctly in opengl. Use the -dx flag if you really want full screen.
  8. emrae

    emrae New Member

    I'm pretty computer illiterate, what a -dx flag?
  9. Clonest

    Clonest Active Member

    just right click on the shortcut to the game then click properties and where you see Target: "C:\Program Files\Maxis\The Sims Online\TSOClient\FreeSO.exe" just put a space and add -dx next to it and hit apply. The next time you start the game that should trigger it. :)
    Last edited: Jun 20, 2016
    Rae likes this.

Share This Page