Version 0.1.5

Discussion in 'Releases' started by Afr0, Jan 23, 2014.

Thread Status:
Not open for further replies.
  1. Afr0

    Afr0 Well-Known Member

    Servers are back up, and the latest version has been released at Github.
    There's also a new version released as a separate update which will be downloaded when you click the shortcut on the desktop. Login server no longer accepts connections from old clients, which will hopefully make it more stable.
    From now on, updates will be distributed exclusively through the updating system, and will be available automatically when you run the updater.

    I've tried my best to make the system idiot proof, but I'm sure you guys will find some way to break something! :D
    Please note that the updater can't be shut down before it is finished. This is to prevent crashes.
  2. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    The updater fills up the file bar at mega speed then crashes for me. It crashes instantly if I answer yes to a backup.

    EDIT: It also says there are no Maxis projects on my system, which there clearly are.
  3. liinor

    liinor Member

    Desktop icon says no maxis installed on pc although it is and project doll house icon from tso home folder worked before update and yes for me it crahsed instantly too after finished update + when choosed yes to backup.

    And now my Project Doll house keeps crashing when I'm trying to launch it.
    When launching project doll house from home folder it crashes instantly but when launching from desktop it says no maxis found from system and could not find manifest - unable to update!
    It worked before patch :I.
  4. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    More on backup crash:
    It completely fails to create the Backup folder and crashes if it does not exist. If it does, it copies some DLLs in and still crashes. My guess is that it's failing to create directories.
  5. AquilaSim

    AquilaSim Administrator Staff Member Moderator

    Me too, I get :
    Error: No Maxis products were found on your system.
    Couldn't find manifest - unable to update!

    Yet I uninstalled completely TSO of my PC and I reinstall and install the latest version of projet to be sure it works but its not work... :(
  6. hepler08

    hepler08 Member

    If I click "yes" when asked to backup data before updating, I get an error stating the PD Patcher has stopped working. When I click "no" I am able to update the client and am taken to the loading screen for PD. When prompted to log in, I still get the is unavailable message. I tried logging in with my own account ID and also the default username:username password:password account. Neither worked. :geek:
  7. Tourniquet

    Tourniquet Member

    Yes i've got the same problem, BUT if i run the updater in admin mode, it does replace files, but it still crashes.

    I now have a newer Project Dollhouse Client, but this also crashes. The one before worked.
  8. Afr0

    Afr0 Well-Known Member

    But... arrgghhh! I spent like three hours testing and debugging it yesterday! *tears hair out*

    Tourniquet: At which point does the updater crash? And at which point does the client crash?

    hepler08: You were able to update? And the updater didn't crash?

    Rhys: Updater clearly needs to be run in admin mode to create directories, that much seems clear by now. I have no f'in clue why it wouldn't find TSO, it uses exactly the same code as the client. :(

    Anyhow, I''ll run the client today and see if I can log on. I might have to create a new update. As for the updater, I guess I'll have to make it produce a log and release it as a separate download.

    Thanks for testing!
  9. zephyr2

    zephyr2 New Member

    How are you guys managing to bypass the "No Maxis products were found" error?

    After I click OK, it says "Couldn't find manifest, unable to update." This is running it in admin mode.
  10. Afr0

    Afr0 Well-Known Member

    zephyr2: Check if the installer installed "Client.manifest" in your TSOClient folder. If it did, then the updater isn't able to find it because of the registry error (still not sure what's causing that error).
  11. zephyr2

    zephyr2 New Member

    Sorry, I was using the wrong file >_<... Let me check the right one.

    - Launching from desktop (shortcut created to PDBootstrap), gives 'No Maxis Product' and 'Cannot find manifest.' And yes, the manifest file is there.
    - Launching PDBootstrap directly from within the TSOClient folder brings up 'Backup data?' When I hit no, it opens the patcher, starts to patch, fills bar quickly, then crashes. When I hit yes, it crashes straight away.

    Edit 2:
    - The installer creates the shortcut on the desktop. However, it specifies that the shortcut "Start in: "C:\Program Files\Maxis\The Sims Online\TSOClient\Content\Effects" which, of course, is not the right place it should be looking. I changed it to point to TSOClient's directory, and it runs without giving the manifest error, but again still crashes.
  12. Afr0

    Afr0 Well-Known Member

    Ah, so there's a problem with the shortcut.
    That's the first concrete bug reported so far. Thanks! :)
  13. Tori Sim

    Tori Sim Active Member

    I noticed in the Compatibility it doesn't have Win XP on there, just Vista and Win 7 - could that cause a problem?
    Also if I choose No to backup before updating, it starts the update but then crashes
  14. xezno

    xezno Member

    Really? I have all of the OSes up to Windows 95 on Vista... are you using Win8?
  15. FriedPasta

    FriedPasta New Member

    You can't select Windows XP as compatibility-mode directly. You'll have to run the problem solver for compatibility and say it ran fine on an older Windows OS, than it'll select Windows XP for you. But I doubt this will solve anything...

    Anyhow, I suffer from the same problems as zephyr2.
    Afr0, are perhaps using a 32-bit OS? Because I think I found the solution for the first problem: registry entries for 32-bit programs on 64-bits OS'es are a little bit different as you can see below.
    In your code you don't check if Wow6432Node exists and if so use it, therefore TSO can't be found on a 64-bit OS.
  16. Afr0

    Afr0 Well-Known Member

  17. Afr0

    Afr0 Well-Known Member

    Guys, try this version.
    It should fix (most of?) your issues. Please put it in the TSOPatch folder. If it crashes, it should produce a log at C:\PDPatcher.txt

    If it doesn't crash, remember to create a desktop shortcut to TSOClient\PDBootstrapper and use that the next time you want to run the game.
  18. RHY3756547

    RHY3756547 FreeSO Developer Staff Member Moderator

    I didn't think anyone used 32-bit windows anymore... Well, whatever! I'll be able to test in an hour or two.
  19. FriedPasta

    FriedPasta New Member

    I've tried that version, still doesn't work.

    You're are right about the redirection, I accidently compiled it as a 64-bit application, so it wasn't redirecting to the right registry key.

    Anyhow, after I forced it to compile at 32-bit the updater and everything works fine. Still your version doesn't work at all, there's even no log being created.
  20. rmaster581

    rmaster581 Member

Thread Status:
Not open for further replies.

Share This Page